Ask Your Question
0

ceilometer: dpkg error processing of ceilometer packages due to dependency problems

asked 2016-12-08 00:02:33 -0500

updated 2016-12-08 00:03:19 -0500

Having hard time installing Ceilometer on Ubuntu 14.04

Openstack liberty

> Distributor ID:   Ubuntu
> Description:  Ubuntu 14.04.5 LTS
> Release:  14.04 Codename: trusty
> 138-Ubuntu SMP Fri Jun 24 17:00:34 UTC
> 2016 x86_64 x86_64 x86_64 GNU/Linux

Complaining about dpkg error processing of ceilometer packages due to dependency problems:

apt-get install ceilometer-api ceilometer-collector \
ceilometer-agent-central ceilometer-agent-notification \
ceilometer-alarm-evaluator ceilometer-alarm-notifier \
python-ceilometerclient

Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed:
ceilometer-common python-ceilometer Suggested packages: python-pysnmp4 The following NEW packages will be installed: ceilometer-agent-central ceilometer-agent-notification
ceilometer-alarm-evaluator ceilometer-alarm-notifier ceilometer-api ceilometer-collector ceilometer-common python-ceilometer
python-ceilometerclient 0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/597 kB of archives. After this operation, 8,214 kB of additional disk space will be used. Do you want to continue? [Y/n] Y Selecting previously unselected package python-ceilometerclient. (Reading database ... 110527 files and directories currently installed.) Preparing to unpack .../python-ceilometerclient_1.0.8-0ubuntu1_all.deb ... Unpacking python-ceilometerclient (1.0.8-0ubuntu1) ... Selecting previously unselected package python-ceilometer. Preparing to unpack .../python-ceilometer_2014.1.5-0ubuntu2_all.deb ... Unpacking python-ceilometer (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-common. Preparing to unpack .../ceilometer-common_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-common (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-agent-central. Preparing to unpack .../ceilometer-agent-central_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-agent-central (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-agent-notification. Preparing to unpack .../ceilometer-agent-notification_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-agent-notification (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-alarm-evaluator. Preparing to unpack .../ceilometer-alarm-evaluator_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-alarm-evaluator (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-alarm-notifier. Preparing to unpack .../ceilometer-alarm-notifier_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-alarm-notifier (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-api. Preparing to unpack .../ceilometer-api_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-api (2014.1.5-0ubuntu2) ... Selecting previously unselected package ceilometer-collector. Preparing to unpack .../ceilometer-collector_2014.1.5-0ubuntu2_all.deb ... Unpacking ceilometer-collector (2014.1.5-0ubuntu2) ... Processing triggers for ureadahead (0.100.0-16) ... Setting up python-ceilometerclient (1.0.8-0ubuntu1) ... Setting up python-ceilometer (2014.1.5-0ubuntu2) ... Setting up ceilometer-common (2014.1.5-0ubuntu2) ... Traceback (most recent call last): File "/usr/bin/ceilometer-dbsync", line 6, in <module> from ceilometer.cli import storage_dbsync File "/usr/lib/python2.7/dist-packages/ceilometer/cli.py", line 32, in <module> from oslo.config import cfg ImportError: No module named config dpkg: error processing package ceilometer-common (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of ceilometer-agent-central: ceilometer-agent-central depends on ceilometer-common (= 2014.1.5-0ubuntu2); however: Package ceilometer-common is not configured yet.

dpkg: error processing package ceilometer-agent-central (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of ceilometer-agent-notification: ceilometer-agent-notification depends on ceilometer-common (= 2014.1.5-0ubuntu2); however: Package ceilometer-common is not configured yet.

dpkg: error processing package ceilometer-agent-notification (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of ceilometer-alarm-evaluator: ceilometer-alarm-evaluator depends on ceilometer-common (= 2014.1.5-0ubuntu2); however: Package ceilometer-coNo apport report written because the error message indicates its a followup error from a previous failure. No apport report written because the error message indicates its a followup error from a previous failure. No apport report written ...

(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-12-08 00:26:36 -0500

Solved the issue by installing the appropriate liberty repository

apt-get install software-properties-common
add-apt-repository cloud-archive:liberty
apt-get update && apt-get dist-upgrade
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-08 00:02:33 -0500

Seen: 146 times

Last updated: Dec 08 '16