Ask Your Question

Revision history [back]

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

UPDATE:

Your nova.conf for host1 is different from host2 and host3.

Host2 and Host3 nova.conf are missing the libvirt info necessary to use rbd:

[libvirt]
images_rbd_pool=novapool
images_type=rbd
rbd_secret_uuid=xxxxxxxxx
rbd_user=novapool

Please add that to nova.conf for host2 and host3 and restart nova-compute service. That should fix it.

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

UPDATE:

Your nova.conf for host1 is different from host2 and host3.

Host2 and Host3 nova.conf are missing the libvirt info necessary to use rbd:

[libvirt]
images_rbd_pool=novapool
images_type=rbd
rbd_secret_uuid=xxxxxxxxx
rbd_user=novapool

Please add that to nova.conf for host2 and host3 and restart nova-compute service. That should fix it.

ETA: There are other differences between host1 nova.conf and host2 and host3's nova.conf. You should go through the nova.conf line-by-line to ensure all the settings are proper and they should be virtually identical across all hosts--except for a few settings specific to each host such as my_ip = x.x.x.x or vncserver_listen = x.x.x.x which are specific to that host.

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

UPDATE:

Your nova.conf for host1 is different from host2 and host3.

Host2 and Host3 nova.conf are missing the libvirt info necessary to use rbd:

[libvirt]
images_rbd_pool=novapool
images_type=rbd
rbd_secret_uuid=xxxxxxxxx
rbd_user=novapool

Please add that to nova.conf for host2 and host3 and restart nova-compute service. That should fix it.

ETA: There are other differences between host1 nova.conf and host2 and host3's nova.conf. You should go through the nova.conf line-by-line to ensure all the settings are proper and they should be virtually identical across all hosts--except for a few settings specific to each host such as my_ip = x.x.x.x or vncserver_listen = x.x.x.x which are specific to that host.

ETA2:

When you sync up the settings on all nova.conf files you'll need to restart scheduler service as well.

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

UPDATE:

Your nova.conf for host1 is different from host2 and host3.

Host2 and Host3 nova.conf are missing the libvirt info necessary to use rbd:

[libvirt]
images_rbd_pool=novapool
images_type=rbd
rbd_secret_uuid=xxxxxxxxx
rbd_user=novapool

Please add that to nova.conf for host2 and host3 and restart nova-compute service. That should fix it.

ETA: There are other differences between host1 nova.conf and host2 and host3's nova.conf. You should go through the nova.conf line-by-line to ensure all the settings are proper and they should be virtually identical across all hosts--except for a few settings specific to each host such as my_ip = x.x.x.x or vncserver_listen = x.x.x.x which are specific to that host.

ETA2:

When you sync up the settings on all nova.conf files you'll need to restart scheduler service as well.

well. Your host2 and host3 nova.conf are missing scheduler settings.

1st, if you are using Ceph there is no need for RAID. It'll impact performance and you'll incur the overhead of RAID _and_ the overhead of Ceph.

http://www.techrepublic.com/article/why-ceph-could-be-the-raid-replacement-the-enterprise-needs/

What do you see if you do a ceph -s?

You appear to be missing AggregateDiskFilter and AggregateCoreFilter.

See the Mitaka scheduler doc at: http://docs.openstack.org/mitaka/config-reference/compute/scheduler.html

You may also need to update some other settings as well for volumes (cinder) and images (glance) sections to use rbd.

Can you post your nova.conf for host 2 and/or host 3 in its entirety? Or, you can just look at host1's nova.conf and compare it to host2 and host3 and see if there are differences.

Probably wouldn't hurt to post the /etc/ceph/ceph.conf file details as well to see how your Ceph is setup.

UPDATE:

Your nova.conf for host1 is different from host2 and host3.

Host2 and Host3 nova.conf are missing the libvirt info necessary to use rbd:

[libvirt]
images_rbd_pool=novapool
images_type=rbd
rbd_secret_uuid=xxxxxxxxx
rbd_user=novapool

Please add that to nova.conf for host2 and host3 and restart nova-compute service. That should fix it.

ETA: There are other differences between host1 nova.conf and host2 and host3's nova.conf. You should go through the nova.conf line-by-line to ensure all the settings are proper and they should be virtually identical across all hosts--except for a few settings specific to each host such as my_ip = x.x.x.x or vncserver_listen = x.x.x.x which are specific to that host.

ETA2:

When you sync up the settings on all nova.conf files you'll need to restart scheduler service as well. Your host2 and host3 nova.conf are missing scheduler settings.

ETA3:

Did that work for you?