Ask Your Question

Revision history [back]

Double check your credentials in glance-api.conf and glance-registry.conf

In my case that was wrong variable name "auth_tenant_name" instead of "admin_tenant_name"

file /etc/glance/glance-api.conf

    [keystone_authtoken]
    auth_uri = http://controller:5000/
    auth_host = controller
    auth_port = 35357
    auth_protocol = http
    admin_tenant_name = service
    admin_user = glance
    admin_password = <yourpass>

file /etc/glance/glance-registry.conf

    # comment all [keystone_authtoken] 
    [keystone_authtoken]
    auth_uri = http://controller:5000
    auth_host = controller
    auth_port = 35357
    auth_protocol = http
    admin_tenant_name = service
    admin_user = glance
    admin_password = <yourpass>

Double check your credentials in glance-api.conf and glance-registry.conf

In my case that was wrong variable name "auth_tenant_name" instead of "admin_tenant_name"

file /etc/glance/glance-api.conf

    [keystone_authtoken]
    auth_uri = http://controller:5000/
    auth_host = controller
    auth_port = 35357
    auth_protocol = http
    admin_tenant_name = service
    admin_user = glance
    admin_password = <yourpass>

file /etc/glance/glance-registry.conf

 # comment all [keystone_authtoken] 
    [keystone_authtoken]
    auth_uri = http://controller:5000
    auth_host = controller
    auth_port = 35357
    auth_protocol = http
    admin_tenant_name = service
    admin_user = glance
    admin_password = <yourpass>