Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Seems, Its default v1 showing in mitaka. Below are the suggested changes to get LBaas v2.0 running for packstack, but before making any changes, Please take backup of the files which you are making changes.

In /etc/neutron/neutron.conf comment the existing line for service_plugins and add below line.

service_plugins = neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2,neutron.services.l3_router.l3_router_plugin.L3RouterPlugin

In /etc/neutron/neutron_lbaas.conf if this file is not there, create it. Comment the existing line for service_provider and add below line.

service_provider = LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

In /etc/neutron/lbaas_agent.ini, comment the existing line for device_driver and add below line.

device_driver = neutron_lbaas.drivers.haproxy.namespace_driver.HaproxyNSDriver

Then, You need run below commands.

# neutron-db-manage --service lbaas upgrade head
# systemctl disable neutron-lbaas-agent.service
# systemctl stop neutron-lbaas-agent.service
# systemctl restart neutron-server.service
# systemctl enable neutron-lbaasv2-agent.service
# systemctl start neutron-lbaasv2-agent.service

Verify that lbaasv2 agent is running.

ps -ef | grep 'neutron-lbaasv2'  |grep -v grep

Then you need to create Loadbalancer using LbaaSv2, listener in that Loadbalancer, pool in that listener

Reference: Please refer to this article