Ask Your Question

Revision history [back]

Using field to post questions as comment :-

Please, post ml2_conf.ini && openvswitch-agent.ini on Controller and Compute nodes, comment which one openvswitch-agent.ini is set up on Controller which one on Compute. What says neutron-ovs-agent on Compute node ? Check log. Also check rabbitmq-server status on Controller. BR-EX is not required on Compute, unless you run DVR configuration. I would expect interprocess communications between Neutron Server (controller) and neutron-ovs-agent (compute) to be broken, in other words it is misconfigured , i.e. has not been properly set up

Using field to post questions as comment :-

Please, post ml2_conf.ini && openvswitch-agent.ini on Controller and Compute nodes, comment which one openvswitch-agent.ini is set up on Controller which one on Compute. What says neutron-ovs-agent on Compute node ? Check log. Also check rabbitmq-server status on Controller. BR-EX is not required on Compute, unless you run DVR configuration. I would expect interprocess communications between Neutron Server (controller) and neutron-ovs-agent (compute) to be broken, in other words it is misconfigured , i.e. - has not been properly set up

Using field to post questions as comment :- UPDATE 08/11/16
I grabed and filtered

[boris@CentOSVirt72 ~]$ cat openvswitch_agent.ini | grep -v ^#|grep -v ^$
[ovs]
[agent]
[securitygroup]

So OVS neutron agent is crashing on any node
END UPDATE

Please, post ml2_conf.ini && openvswitch-agent.ini on Controller and Compute nodes, comment which one openvswitch-agent.ini is set up on Controller which one on Compute. What says neutron-ovs-agent on Compute node ? Check log. Also check rabbitmq-server status on Controller. BR-EX is not required on Compute, unless you run DVR configuration. I would expect interprocess communications between Neutron Server (controller) and neutron-ovs-agent (compute) to be broken, in other words it is misconfigured - has not been properly set up

UPDATE 08/11/16
I grabed and filtered

[boris@CentOSVirt72 ~]$ cat openvswitch_agent.ini | grep -v ^#|grep -v ^$
[ovs]
[agent]
[securitygroup]

So OVS neutron agent is crashing on any node
For instance sample generated via TrpipleO setting up HA Controller (ML2&OVS&VXLAN)

[root@overcloud-controller-0 ml2]# cat openvswitch_agent.ini | grep -v ^#|grep -v ^$
[DEFAULT]
[agent]
tunnel_types =vxlan
vxlan_udp_port = 4789
l2_population = False
drop_flows_on_start = False
extensions=qos
[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 172.16.0.4
bridge_mappings =datacentre:br-ex
enable_tunneling=True
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

In case of vlan's tenant segregation file above should be updated disabling tunneling
and setting up bridge_mappings for vlan connection Controller and Compute Nodes.
END UPDATE

Please, post ml2_conf.ini && openvswitch-agent.ini on Controller and Compute nodes, comment which one openvswitch-agent.ini is set up on Controller which one on Compute. What says neutron-ovs-agent on Compute node ? Check log. Also check rabbitmq-server status on Controller. BR-EX is not required on Compute, unless you run DVR configuration. I would expect interprocess communications between Neutron Server (controller) and neutron-ovs-agent (compute) to be broken, in other words it is misconfigured - has not been properly set up