Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Below is part of my dnsmasq.conf

Send options to PXELinux. Note that we need to send the options even

though they don't appear in the parameter request list, so we need

to use dhcp-option-force here.

See http://syslinux.zytor.com/pxe.php#special for details.

Magic number - needed before anything else is recognised

dhcp-option-force=208,f1:00:74:7e

Configuration file name

dhcp-option-force=209,configs/common

Path prefix

dhcp-option-force=210,/tftpboot/pxelinux/files/

Reboot time. (Note 'i' to send 32-bit value)

dhcp-option-force=211,30i

dhcp-option-force=26,1450

I updated as above and restart neutron-dhcp-agent service But it did not work.

My env has two nics, one is for management ip and the other is used for openstack And my network ml2 is OVS

I did check by use tcpdump to track, seemed packet was received and responsed For example

[root@test18177 etc]# ip a 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether fa:16:3e:bd:3a:43 brd ff:ff:ff:ff:ff:ff inet 108.11.11.3/24 brd 108.11.11.255 scope global dynamic eth0 valid_lft 83554sec preferred_lft 83554sec 3: eth1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether fa:16:3e:f0:74:ea brd ff:ff:ff:ff:ff:ff

[root@test18177 etc]# tcpdump -i eth1 -v tcpdump: WARNING: eth1: no IPv4 address assigned tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes

Run command tcpdump -i eth1 -v

05:40:25.012497 IP (tos 0x0, ttl 64, id 3216, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 1, length 64 05:40:25.015012 IP (tos 0x0, ttl 63, id 64928, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 1, length 64 05:40:26.011599 IP (tos 0x0, ttl 64, id 3217, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 2, length 64 05:40:26.012375 IP (tos 0x0, ttl 63, id 65109, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 2, length 64 05:40:27.011620 IP (tos 0x0, ttl 64, id 3218, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 3, length 64 05:40:27.012155 IP (tos 0x0, ttl 63, id 65279, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 3, length 64 05:40:28.011844 IP (tos 0x0, ttl 64, id 3219, offset 0, flags [DF], proto ICMP (1), length 84) test18177 > 108.11.11.226: ICMP echo request, id 29548, seq 4, length 64 05:40:28.012383 IP (tos 0x0, ttl 63, id 65469, offset 0, flags [none], proto ICMP (1), length 84) 108.11.11.226 > test18177: ICMP echo reply, id 29548, seq 4, length 64 05:40:30.015705 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 108.11.11.226 tell test18177, length 28 05:40:30.015918 ARP, Ethernet (len 6), IPv4 (len 4), Reply 108.11.11.226 is-at fa:16:3e:a3:ba:8c (oui Unknown), length 28

Seemed from above track record, nic did receive response But seemed some drop packet so ping not work

Thanks!