Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Managed to enable nested KVM for compute node:

  1. Updated kernel on both the baremetal and compute to 3.18.
  2. Enable nested KVM on baremetal

    vi /etc/modprobe.d/kvm-nested.conf options kvm_intel nested=1

    modprobe -r kvm_intel # unload modprobe kvm_intel # reload again

    Check that nested KVM is enabled cat /sys/module/kvm_intel/parameters/nested

    Y# just enabled

  3. Pass HW virtualization flag to the compute VM

    virsh edit <compute domain="">

    <cpu mode="host-passthrough"/>

  4. Update nova service on compute node in order to use kvm instead of qemu

    vi /etc/nova/nova.conf virt_type=kvm cpu_mode=host-passthrough

    service openstack-nova-compute restart