Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Could you provide command response of "neutron net-list" and "neutron net-show your_external_network, such as (in my case is Mitaka and external_network name is "ext-net").

root@nuc1 ~(admin)# neutron net-list
+--------------------------------------+----------+-----------------------------------------------------+
| id                                   | name     | subnets                                             |
+--------------------------------------+----------+-----------------------------------------------------+
| 391b9818-0527-4cb5-90fd-808385611317 | ext-net  | 659aba27-6163-4fa0-abbe-6b05a3d8bbda 192.168.0.0/24 |
| d811d627-efe7-48e7-b0ae-092868a68884 | private2 | 5f24a0c5-bcfa-4b47-af50-501426bec9dd 10.0.1.0/24    |
| 4e43414b-b2ea-4336-b960-d5af31e3bcb4 | private1 | bf62fddf-dcf9-42ff-8d54-fdd0666be7f9 10.0.0.0/24    |
+--------------------------------------+----------+-----------------------------------------------------+

root@nuc1 ~(admin)# neutron net-show ext-net
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| availability_zone_hints   |                                      |
| availability_zones        | nova                                 |
| created_at                | 2016-05-09T11:15:35                  |
| description               |                                      |
| id                        | 391b9818-0527-4cb5-90fd-808385611317 |
| ipv4_address_scope        |                                      |
| ipv6_address_scope        |                                      |
| is_default                | False                                |
| mtu                       | 1500                                 |
| name                      | ext-net                              |
| port_security_enabled     | True                                 |
| provider:network_type     | flat                                 |
| provider:physical_network | external                             |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 659aba27-6163-4fa0-abbe-6b05a3d8bbda |
| tags                      |                                      |
| tenant_id                 | 65bbe5e9c8504fd4b3da39339dc51350     |
| updated_at                | 2016-05-15T06:45:33                  |
+---------------------------+--------------------------------------+

"physical_interface_mappings" in /etc/neutron/plugins/ml2/linuxbridge_agent.ini should be;
physical_interface_mappings = provider:physical_network : interface_name
e.g. physical_interface_mappings = external: eth0

Because eth1 is unnumberd, you also need to specify eth0 (numbed interface) in physical_interface_mappings.

Additionally, set ;

[ml2_type_flat]
flat_networks = external   # ==> provider:physical_network name

in /etc/neutron/plugins/ml2/ml2_conf.ini

After config files restart neutron processes (or reboot controller and compute node), then crate external network with command;

neutron net-create public-net \
        --router:external \
        --provider:network_type flat \
        --provider:physical_network external \
        --shared

neutron subnet-create public-net --name public-subnet \
      --allocation-pool start=172.18.1.195,end=172.18.1.230 \
      --disable-dhcp --gateway 172.18.0.1  172.10.0.0/22

neutron router-create  ext-router

neutron router-gateway-set ext-router public-net

Befor to create public-net with the above command it is better to delete all network and router, then re-create public network, router and set router gateway