Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

possibly break this into 2 problems: 1. make sure you can reliably get the new user created and you can see it in passwd file and home dir is created. Here's what works for me with Ubuntu 14.04 VM : users: - default - name: user01 groups: lock-passwd: false passwd: 's0oC/Amo1kHG6' shell: /bin/bash sudo: "ALL=(ALL) NOPASSWD:ALL" ssh_pwauth: true if you don't want the default user or pwauth, then remove those parts.

  1. after new user is created in VM, get PKI working. Pass the nova keypair name when createing the VM: type: "OS::Nova::Server" properties: name: my_vm image: { get_param: image } flavor: { get_param: flavor } key_name: { get_param: key_name }

When you attempt 'ssh -i privatekey.pem user@0.1.2.3' make sure you're using a private key which was created with the public keyname which you passed to ::Server in the template above. Make sure that PKI is enabled in /etc/ssh. If you can get into VM (possibly thru horizon instance console login), watch /var/log/auth.log to see what happens when you attemp ssh from outside.

possibly break this into 2 problems: 1. make sure you can reliably get the new user created and you can see it in passwd file and home dir is created. Here's what works for me with Ubuntu 14.04 VM : users: - default - name: user01 groups: lock-passwd: false passwd: 's0oC/Amo1kHG6' shell: /bin/bash sudo: "ALL=(ALL) NOPASSWD:ALL" ssh_pwauth: true if you don't want the default user or pwauth, then remove those parts.

  1. 2. after new user is created in VM, get PKI working.
    Pass the nova keypair name when createing the VM:
    type: "OS::Nova::Server"
     properties:
       name: my_vm
       image: { get_param: image }
       flavor: { get_param: flavor }
       key_name: { get_param: key_name }
}

When you attempt 'ssh -i privatekey.pem user@0.1.2.3' make sure you're using a private key which was created with the public keyname which you passed to ::Server in the template above. Make sure that PKI is enabled in /etc/ssh. If you can get into VM (possibly thru horizon instance console login), watch /var/log/auth.log to see what happens when you attemp ssh from outside.

possibly break this into 2 problems: problems:

1. make sure you can reliably get the new user created and you can see it in passwd file and home dir is created.
Here's what works for me with Ubuntu 14.04 VM :
        users:
        - default
        - name: user01
          groups: 
          lock-passwd: false
          passwd: 's0oC/Amo1kHG6' 
          shell: /bin/bash
          sudo: "ALL=(ALL) NOPASSWD:ALL"
        ssh_pwauth: true
if you don't want the default user or pwauth, then remove those parts.

parts.

2. after new user is created in VM, get PKI working.
Pass the nova keypair name when createing the VM:
type: "OS::Nova::Server"
    properties:
      name: my_vm
      image: { get_param: image }
      flavor: { get_param: flavor }
      key_name: { get_param: key_name }

When you attempt 'ssh -i privatekey.pem user@0.1.2.3' make sure you're using a private key which was created with the public keyname which you passed to ::Server in the template above. Make sure that PKI is enabled in /etc/ssh. If you can get into VM (possibly thru horizon instance console login), watch /var/log/auth.log to see what happens when you attemp ssh from outside.