Ask Your Question

Revision history [back]

We run official CI tests of horizon changes on Ubuntu 14.04 at the moment, and don't see that error. For example, this ran yesterday on a change which was subsequently merged:

http://logs.openstack.org/79/316279/3/gate/gate-horizon-python34/2d50b59/console.html.gz

When did this first start? Was it working for you up until recently? Also, where did you obtain your Python 3.4 interpreter for Ubuntu 12.04? As http://packages.ubuntu.com/python3.4 reflects, it was not officially packaged and distributed in Ubuntu until 14.04 LTS (Trusty Tahr).

We run official CI tests of horizon changes on Ubuntu 14.04 at the moment, and don't see that error. For example, this ran yesterday on a change which was subsequently merged:

http://logs.openstack.org/79/316279/3/gate/gate-horizon-python34/2d50b59/console.html.gz

When did this first start? Was it working for you up until recently? Also, where did you obtain your Python 3.4 interpreter for Ubuntu 12.04? As http://packages.ubuntu.com/python3.4 reflects, it was not officially packaged and distributed in Ubuntu until 14.04 LTS (Trusty Tahr).

Note that bugs in Horizon (including bugs in its unit tests) should be reported to the bug tracker instead: https://bugs.launchpad.net/horizon/+filebug