Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi, I see it's been a while since you asked your question, have you managed it to work? I've been working with Ceph for about a week or two now, and I was facing the same issue. I tried to launch an instance using a Ceph image, and for two or three seconds I saw the newly created disk in the rbd pool, then it disappeared. But when I tried to boot-from-volume via Cinder using the exact same image it worked! I'm quite new to all of this, so I'm not really sure, but I assume that cinder and nova have different approaches accessing rbd images/volumes. Besides configuring Ceph, Cinder, Nova and Glance, please notice that I'm working with Mitaka and xen compute nodes right now. I also tested it with kvm as hypervisor, it worked right away. I should also mention that I have full rights for my ceph client, I tried it with restrictions similar to yours, it didn't work at all. I hope my pointers is helping you or anybode else.