Ask Your Question

Revision history [back]

I had the same issue and i solved it just by reinstalling neutron (uninstalling all packages related to neutron and installing and editing the config files again). I also have to reinstall nova and horizon in the controller node as they were uninstalled too.

To debug it this problem first i get the neutron agent list:

# neutron agent-list

and shows that one of the linux bridge agents is not running (in my case the one in the controller node), the field 'Alive' is XXX. Also, the port in the router that acts as the interface of the public network shows that the binding:vif_type is binding_fail:

# neutron port-show <id-puerto-router-gateway>
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| Field                 | Value                                                                                                                 |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                                                  |
| allowed_address_pairs |                                                                                                                       |
| binding:host_id       | puccini                                                                                                               |
| binding:profile       | {}                                                                                                                    |
| binding:vif_details   | {"port_filter": true}                                                                                                 |
| binding:vif_type      | binding_fail                                                                                                               |
| binding:vnic_type     | normal                                                                                                                |
| device_id             | ccb7fd27-a791-4033-96ab-6aee33edcbda                                                                                  |
| device_owner          | network:router_gateway                                                                                                |
| dns_assignment        | {"hostname": "host-163-117-141-129", "ip_address": "163.117.141.129", "fqdn": "host-163-117-141-129.openstacklocal."} |
| dns_name              |                                                                                                                       |
| extra_dhcp_opts       |                                                                                                                       |
| fixed_ips             | {"subnet_id": "7f6d387c-4edb-4e52-a594-0cbd67712c3a", "ip_address": "163.117.141.129"}                                |
| id                    | c13cad36-05d9-405e-a677-d95c3ea01d6b                                                                                  |
| mac_address           | fa:16:3e:f4:36:39                                                                                                     |
| name                  |                                                                                                                       |
| network_id            | 3a39126e-748b-45b5-8169-6eee192fae29                                                                                  |
| port_security_enabled | False                                                                                                                 |
| security_groups       |                                                                                                                       |
| status                | DOWN                                                                                                                |
| tenant_id             |                                                                                                                       |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+

Jonathan

I had the same issue and i solved it just by reinstalling neutron (uninstalling all packages related to neutron and installing and editing the config files again). I also have to reinstall nova and horizon in the controller node as they were uninstalled too.

To debug it this problem first i get the neutron agent list:

# neutron agent-list

and shows that one of the linux bridge agents is not running (in my case the one in the controller node), the field 'Alive' is XXX. Also, the port in the router that acts as the interface of the public network shows that the binding:vif_type is binding_fail:

# neutron port-show <id-puerto-router-gateway>
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| Field                 | Value                                                                                                                 |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                                                  |
| allowed_address_pairs |                                                                                                                       |
| binding:host_id       | puccini                                                                                                               |
| binding:profile       | {}                                                                                                                    |
| binding:vif_details   | {"port_filter": true}                                                                                                 |
| binding:vif_type      | binding_fail                                                                                                               |
| binding:vnic_type     | normal                                                                                                                |
| device_id             | ccb7fd27-a791-4033-96ab-6aee33edcbda                                                                                  |
| device_owner          | network:router_gateway                                                                                                |
| dns_assignment        | {"hostname": "host-163-117-141-129", "ip_address": "163.117.141.129", "fqdn": "host-163-117-141-129.openstacklocal."} |
| dns_name              |                                                                                                                       |
| extra_dhcp_opts       |                                                                                                                       |
| fixed_ips             | {"subnet_id": "7f6d387c-4edb-4e52-a594-0cbd67712c3a", "ip_address": "163.117.141.129"}                                |
| id                    | c13cad36-05d9-405e-a677-d95c3ea01d6b                                                                                  |
| mac_address           | fa:16:3e:f4:36:39                                                                                                     |
| name                  |                                                                                                                       |
| network_id            | 3a39126e-748b-45b5-8169-6eee192fae29                                                                                  |
| port_security_enabled | False                                                                                                                 |
| security_groups       |                                                                                                                       |
| status                | DOWN                                                                                                                |
| tenant_id             |                                                                                                                       |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+

It is also worth mentioning that the official guide of liberty installation lacks some configuration parameters (as described here and here, which causes the following failure when trying to boot instances:

ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.<class 'keystoneclient.exceptions.BadRequest'> (HTTP 500) (Request-ID: req-7acc4f88-51fc-4c0b-9748-361a2e9a6ad9)

Jonathan