Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

So after days of trying to solve this challenge, I've finally found the cause. My environment is run on my workstation using VMware Workstation. I setup the interface for my all in one VM to use the NAT virtual network.

The solution to my problem was first set the network to use a static IP, then to edit the VMware workstation virtual network settings to turn off the "Use local DHCP service to distribute IP addresses to VMs" setting for the NAT network.

Once that was turned off, all of the images deployed through openstack are getting IPs assigned from the internal 10.0.0.0 network.

One thing to note about this solution is that if you have other VMs running in your VMware Workstation, and they are using NAT networking, you will have to set them all to use a static IP configuration because you can only have 1 NAT interface in VMware Workstation. I will be looking at creating custom network interfaces using the "Add Network" feature of the VMware Workstation "Edit Virtual Networks" feature.

Hope this info helps the next person. :-) Thanks.