Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi,

I have the same error The request you have made requires authentication. HTTP 401

I have Centos7, disabled SELinux & firewalld.

I am using: http://docs.openstack.org/liberty/install-guide-rdo/keystone-services.html

I run:

openstack service create --debug --name keystone --description "OpenStack Identity" identity

I see:

    ...
        RESP BODY: {"error": {"message": "The request you have made requires authentication.","code": 401, "title": "Unauthorize"}}
    ....

Request returned failure status: 401

I have got only httpd running.

netstat -tulpn 
tcp6     0       0  :::35357                :::*        LISTEN                  1947/httpd
tcp6     0       0  :::5000                 :::*        LISTEN                  1947/httpd

According to Liberty Installation Guide only httpd service should be started. I have tried to start openstack-keystone.service unfortunately it cannot be started - the port is already assigned to httpd.

I have exported

export OS_TOKEN=294a4c8a8a475f9b9836      #the same as in /etc/keystone/keystone.conf
export OS_URL=http://controller:35357/v3
export OS_IDENTITY_API_VERSION=3

I can manually login into mysql using user keystone with password configured in /etc/keystone/keystone.conf

I look forward for suggestions how to fix the bug.