Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You can delete the openstack folder under .config path in your home dir. and stack it again. It should work.

This is because of clouds.yaml file present in the user's home directory under .config/openstack folder. The auth_url in clouds.yaml is pointing to v2.0 where as the identity API version the openstack client is talking to is version 3 and hence it throws the above error. The openstack-client internally checks the environment namepsace variables set in the system including defaults and cloud config. The cloud config variables override the defaults set in the cloud and will be the ones used by openstack-client if at all they exist in the user's system in clouds.yaml . Hope this helps.