Ask Your Question

Revision history [back]

Had the same Problem in my setup with two controllers and haproxy. Fixed it by setting registry_host = [MY_vIP] in glance-api.conf where [MY_vIP] is the IP of the haproxy. Maybe try setting it to your controllers IP. Don't forget to restart glance-api afterwards.

Had the solution from this answer.