Ask Your Question

Revision history [back]

Don't have Fedora 22 available, but on Fedora 21 is the same.

grep PasswordAuthentication /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication yes

Changed to: grep PasswordAuthentication /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication no

Then created snaphot and fresh instance from the snapshot and instance from shapshot and: grep PasswordA /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication yes

I believe cloud-init included in cloud Fedora images overwrites this setting. You can: 1. use puppet/chef/ansible to manage configuration 2. try setting chattr +i on that file before snapshot (but it can cause problems with cloud-init)