Ask Your Question

Revision history [back]

Updating registry_host is not the exact solution if you are running glance,nova and identity on the same machine.

The exact solution for the problem is either we have applied wrong configuration settings in glance-registry.conf file or typo errors.

Fix would be :

Systemctl stop openstack-glance-api.service openstack-glance-registry.service

Edit the /etc/glance/glance-registry.conf file and check MySQL connection setting.

Keystone_authentication section.

Paste_policy section.

These configuration options should reflect as per the documentation.

Remove any other configuration options within these sections as they are not required or deprecated in kilo.

After making the necessary changes, source the admin-rc.sh file and issue the command "openstack token issue".

Restart the glance services.

Note: the file permissions on the api and registry files should at least be root:glance for the services to start.

If the above solution did not work, check the glance database table and the records populated in them.

You need to run the command "su /bin/sh -c glance-manage db_sync" to populate the database records.