Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Per the original question, it's not the version of rabbitmq that is the issue, it's the version of the compute RPC API you have, the 3.33 comes from this:

https://github.com/openstack/nova/blob/2014.2/nova/compute/rpcapi.py#L270

So check to see that (1) you have that Juno code level on your compute nodes and (2) check to see if you have versions pinned via the upgrade_levels.compute config option in nova.conf. There is some more info on upgrade_levels in the docs here:

http://docs.openstack.org/openstack-ops/content/ops_upgrades_upgrade_levels.html