Revision history [back]

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing a section for [ovs]
View : http://docs.openstack.org/icehouse/install-guide/install/apt/content/neutron-ml2-compute-node.html

[ovs]
...
local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
tunnel_type = gre
enable_tunneling = True

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

Regarding second error , please post ovs-vsctl show after fixing first error.

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing a section for [ovs][ovs] and [agent]
View : http://docs.openstack.org/icehouse/install-guide/install/apt/content/neutron-ml2-compute-node.htmlhttp://docs.openstack.org/kilo/install-guide/install/apt/content/neutron-network-node.html
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...
local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
tunnel_type bridge_mappings = external:br-ex
Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the 

IP address of the instance tunnels network interface on your network node.

In the [agent] section, enable GRE tunnels:
[agent]
...
tunnel_types = gre
enable_tunneling = True

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

Regarding second error , please post ovs-vsctl show after fixing first error.

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing a section for [ovs] and [agent]
View : http://docs.openstack.org/kilo/install-guide/install/apt/content/neutron-network-node.html
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...
 local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
bridge_mappings = external:br-ex
 Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the  
IP address of the instance tunnels network interface on your network node.
 In the [agent] section, enable GRE tunnels:
 [agent]
 ...
tunnel_types = gre

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

Regarding second error , please post ovs-vsctl show after fixing first error.

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing a section sections for [ovs] and [agent]
View : http://docs.openstack.org/kilo/install-guide/install/apt/content/neutron-network-node.html
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...

local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
bridge_mappings = external:br-ex

Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the 
IP address of the instance tunnels network interface on your network node.
In the [agent] section, enable GRE tunnels:


[agent]
    ...
tunnel_types = gre

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

Regarding second error , please post ovs-vsctl show after fixing first error.

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing sections for [ovs] and [agent]
View : http://docs.openstack.org/kilo/install-guide/install/apt/content/neutron-network-node.html http://docs.openstack.org/kilo/install-guide/install/yum/content/neutron-network-node.html
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...

local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
bridge_mappings = external:br-ex

Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the 
IP address of the instance tunnels network interface on your network node.
In the [agent] section, enable GRE tunnels:


[agent]
    ...
tunnel_types = gre

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

Regarding second error , please post ovs-vsctl show after fixing first error.

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing sections for [ovs] and [agent]
View : http://docs.openstack.org/kilo/install-guide/install/yum/content/neutron-network-node.html
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...

local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
bridge_mappings = external:br-ex

Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the 
IP address of the instance tunnels network interface on your network node.
In the [agent] section, enable GRE tunnels:


[agent]
    ...
tunnel_types = gre

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

View also : https://ask.openstack.org/en/question/55080/cannot-provision-gre-network/
Regarding second error , please post ovs-vsctl show after fixing first error.