Revision history [back]

I had the same error due to savanna.conf having host = 10.0.11.100

my ip address instead of localhost. When I commented out this line

host = 10.0.11.100

It worked.

That's because a different interface is used (eth0 not loopback in my case) and the url is echo $SAVANNA_URL http://localhost:8386/v1.0/f51a9d1948db4940b21d362002761e66

as directed by the savanna quickstart guide.

To check this situation, try telnet localhost 8386 and telnet 10.0.11.100 # replacing with your ip

In my case, i could only connect to the ip, until I changed the config as mentioned above.

I believe you can either have all urls with your ip and host = ip or all urls localhost with host = localhost #by default or set explicitly

But you cannot mix the two.

I had the same error due to savanna.conf having host = 10.0.11.100

my ip address instead of localhost. When I commented out this line

# host = 10.0.11.100

It worked.

That's because a different interface is used (eth0 not loopback in my case) and the url is echo $SAVANNA_URL http://localhost:8386/v1.0/f51a9d1948db4940b21d362002761e66

as directed by the savanna quickstart guide.

To check this situation, try telnet localhost 8386 and telnet 10.0.11.100 # replacing with your ip

In my case, i could only connect to the ip, ip not localhost, until I changed the config as mentioned above.

I believe you can either have all urls with your ip and host = ip or all urls localhost with host = localhost #by default or set explicitly

But you cannot mix the two.

I had the same error due to savanna.conf having host = 10.0.11.100

my ip address instead of localhost. When I commented out this line

# host = 10.0.11.100

It worked.

That's because a different interface is used (eth0 not loopback in my case) and the url is is

echo $SAVANNA_URL

http://localhost:8386/v1.0/f51a9d1948db4940b21d362002761e66

as directed by the savanna quickstart guide.

To check this situation, try telnet localhost 8386 and telnet 10.0.11.100 # replacing with your ip

In my case, i could only connect to the ip not localhost, until I changed the config as mentioned above.

I believe you can either have all urls with your ip and host = ip or all urls localhost with host = localhost #by default or set explicitly

But you cannot mix the two.