Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I have VNC working fine with my OpenStack+vSphere deployment. I am connecting to vCenter and not directly to the ESX Hosts. However according to VMWare you do have to open the ports on the hypervisor by either the esxcli, powercli, or the vSphere Client.

On the vSphere Client you select the host then configuration > firewall properties > gdbserver > select the checkbox > click ok. (this is really only for testing purposes) For production you would want to limit the ports to 5900-6000.

Nova.conf (My controller and compute node live on the same server, and this is configuration is for testing only)

[default]
vncserver_proxyclient_address = IP of your Controller
vncserver_listen = 0.0.0.0
vncserver_enabled = True
novncproxy_host = 0.0.0.0
novncproxy_port = 6080
novncproxy_base_url = http://mycontroller:6080/vnc_auto.html

Make sure you have the nova-novncproxy and nova-consoleauth packages installed. If you have your firewall enabled on your controller I would disable it.

I am having problems making SPICE protocol work with vSphere at the moment.