Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks. Below is what I have:

root@sys-n03:~# lsmod | grep kvm
kvm_intel             143590  0
kvm                   452043  1 kvm_intel

root@sys-n03:~# ls -l /dev/kvm
crw-rw---- 1 root kvm 10, 232 Jul 16 15:21 /dev/kvm

No sign of KVM running though:

root@sys-n03:~# ps -ef | grep qemu
libvirt+   2777      1  0 Jul17 ?        00:19:14 /usr/bin/qemu-system-x86_64 -name instance-00000048 -S -machine pc-i440fx-trusty,accel=tcg,usb=off -cpu SandyBridge,+invpcid,+erms,+bmi2,+smep,+avx2,+bmi1,+fsgsbase,+abm,+pdpe1gb,+rdrand,+f16c,+osxsave,+movbe,+dca,+pcid,+pdcm,+xtpr,+fma,+tm2,+est,+smx,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 512 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 48ceba01-fdea-4801-a60e-f81c8b6c843e -smbios type=1,manufacturer=OpenStack Foundation,product=OpenStack Nova,version=2014.2.3,serial=44454c4c-5400-1030-8033-b3c04f313532,uuid=48ceba01-fdea-4801-a60e-f81c8b6c843e -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-00000048.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/disk,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=26,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e:b1:c8:b6,bus=pci.0,addr=0x3 -chardev file,id=charserial0,path=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/console.log -device isa-serial,chardev=charserial0,id=serial0 -chardev pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -k en-us -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

* UPDATE *

CPU Info:

Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz

I think the server surely supports virtualisation and is particularly is ready to run KVM

Running

virsh capabilities

Will output

...
  <domain type='kvm'>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
  </domain>
...

As I installed OpenStack Juno, I notice that there's no nova-compute-kvm package is installed. I don't know it's because qemu kvm has been merged into the mainstream.

* END OF UPDATE *

================

Thanks. Below is what I have:

root@sys-n03:~# lsmod | grep kvm
kvm_intel             143590  0
kvm                   452043  1 kvm_intel

root@sys-n03:~# ls -l /dev/kvm
crw-rw---- 1 root kvm 10, 232 Jul 16 15:21 /dev/kvm

No sign of KVM running though:

root@sys-n03:~# ps -ef | grep qemu
libvirt+   2777      1  0 Jul17 ?        00:19:14 /usr/bin/qemu-system-x86_64 -name instance-00000048 -S -machine pc-i440fx-trusty,accel=tcg,usb=off -cpu SandyBridge,+invpcid,+erms,+bmi2,+smep,+avx2,+bmi1,+fsgsbase,+abm,+pdpe1gb,+rdrand,+f16c,+osxsave,+movbe,+dca,+pcid,+pdcm,+xtpr,+fma,+tm2,+est,+smx,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 512 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 48ceba01-fdea-4801-a60e-f81c8b6c843e -smbios type=1,manufacturer=OpenStack Foundation,product=OpenStack Nova,version=2014.2.3,serial=44454c4c-5400-1030-8033-b3c04f313532,uuid=48ceba01-fdea-4801-a60e-f81c8b6c843e -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-00000048.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/disk,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=26,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e:b1:c8:b6,bus=pci.0,addr=0x3 -chardev file,id=charserial0,path=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/console.log -device isa-serial,chardev=charserial0,id=serial0 -chardev pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -k en-us -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

* UPDATE - SOLVED *

Hi,

I've eventually reinstalled the nova-compute-qemu that its dependency packages, and magically it works this time.

Before that i also attempted to install qemu-kvm as a separate linux packages but it changed nothing, as I guess now that it always comes down qemu that brings the virtualisation, it's only up to the system in whether it supports KVM or not (is it correct?)

Now that when i check the dumpxml of VMs:

root@sys-n07:~/junoscript# virsh dumpxml instance-00000061 | grep kvm
<domain type='kvm' id='31'>
    <emulator>/usr/bin/kvm-spice</emulator>

and

libvirt+  97280      1 11 17:30 ?        00:05:04 qemu-system-x86_64 -enable-kvm -name instance-00000061 -S -machine pc-i440fx-trusty,accel=kvm,usb=off -cpu SandyBridge,+invpcid,+erms,+bmi2,+smep,+avx2,+bmi1,+fsgsbase,+abm,+pdpe1gb,+rdrand,+f16c,+osxsave,+movbe,+dca,+pcid,+pdcm,+xtpr,+fma,+tm2,+est,+smx,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 512 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid acd86f52-d2f7-48f0-a1b2-baad51ff01b3 -smbios type=1,manufacturer=OpenStack Foundation,product=OpenStack Nova,version=2014.2.3

Thanks for your concern!

* END OF UPDATE *

* UPDATE *

CPU Info:

Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz

I think the server surely supports virtualisation and is particularly is ready to run KVM

Running

virsh capabilities

Will output

...
  <domain type='kvm'>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
  </domain>
...

As I installed OpenStack Juno, I notice that there's no nova-compute-kvm package is installed. I don't know it's because qemu kvm has been merged into the mainstream.

* END OF UPDATE *

================

Thanks. Below is what I have:

root@sys-n03:~# lsmod | grep kvm
kvm_intel             143590  0
kvm                   452043  1 kvm_intel

root@sys-n03:~# ls -l /dev/kvm
crw-rw---- 1 root kvm 10, 232 Jul 16 15:21 /dev/kvm

No sign of KVM running though:

root@sys-n03:~# ps -ef | grep qemu
libvirt+   2777      1  0 Jul17 ?        00:19:14 /usr/bin/qemu-system-x86_64 -name instance-00000048 -S -machine pc-i440fx-trusty,accel=tcg,usb=off -cpu SandyBridge,+invpcid,+erms,+bmi2,+smep,+avx2,+bmi1,+fsgsbase,+abm,+pdpe1gb,+rdrand,+f16c,+osxsave,+movbe,+dca,+pcid,+pdcm,+xtpr,+fma,+tm2,+est,+smx,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 512 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 48ceba01-fdea-4801-a60e-f81c8b6c843e -smbios type=1,manufacturer=OpenStack Foundation,product=OpenStack Nova,version=2014.2.3,serial=44454c4c-5400-1030-8033-b3c04f313532,uuid=48ceba01-fdea-4801-a60e-f81c8b6c843e -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-00000048.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/disk,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=26,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e:b1:c8:b6,bus=pci.0,addr=0x3 -chardev file,id=charserial0,path=/var/lib/nova/instances/48ceba01-fdea-4801-a60e-f81c8b6c843e/console.log -device isa-serial,chardev=charserial0,id=serial0 -chardev pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -k en-us -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5