Ask Your Question

Revision history [back]

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414
If you are not on Kilo , I would test suggestion #26,#27

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414
If you are not on Kilo , I would test suggestion suggestions #26,#27

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414
If you are not on Kilo , I would test suggestions #26,#27
If it happens to you on Kilo in nova/virt/libvirt/driver.py there is block

 # Compare CPU
        if not instance.vcpu_model or not instance.vcpu_model.model:
            source_cpu_info = src_compute_info['cpu_info']
            self._compare_cpu(None, source_cpu_info)
        else:
            self._compare_cpu(instance.vcpu_model, None)

You can make a copy of driver.py and attempt to disable comparison. Actually, this block should work for you.

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414
If you are not on Kilo , I would test suggestions #26,#27
If it happens to you on Kilo in nova/virt/libvirt/driver.py there is block

 # Compare CPU
        if not instance.vcpu_model or not instance.vcpu_model.model:
            source_cpu_info = src_compute_info['cpu_info']
            self._compare_cpu(None, source_cpu_info)
        else:
            self._compare_cpu(instance.vcpu_model, None)

You can make a copy of driver.py and attempt to disable comparison. Actually, this block should work for you.you. Did you attempt on Juno or you did something different :-

1) Find lowest common denominator CPU model across all hypervisors using virsh capabilities / virsh cpu-baseline
2) Configure nova-compute.conf to include cpu_mode=custom, cpu_model=Westmere (in my case)
3) Disable the CPU check in nova/virt/libvirt/driver.py (comment out line 4248)
    4246 # Compare CPU
    4247 source_cpu_info = src_compute_info['cpu_info']
    4248 self._compare_cpu(source_cpu_info)

Please , confirm.

Seems like your issue is addressed here https://bugs.launchpad.net/nova/+bug/1082414
If you are not on Kilo , I would test suggestions #26,#27
If it happens to you on Kilo in nova/virt/libvirt/driver.py there is block

 # Compare CPU
        if not instance.vcpu_model or not instance.vcpu_model.model:
            source_cpu_info = src_compute_info['cpu_info']
            self._compare_cpu(None, source_cpu_info)
        else:
            self._compare_cpu(instance.vcpu_model, None)

You can make a copy of driver.py and attempt to disable comparison. Actually, this block should work for you. you.

Did you attempt on Juno or you did something different :-

1) Find lowest common denominator CPU model across all hypervisors using virsh capabilities / virsh cpu-baseline
2) Configure nova-compute.conf to include cpu_mode=custom, cpu_model=Westmere (in my case)
3) Disable the CPU check in nova/virt/libvirt/driver.py (comment out line 4248)
    4246 # Compare CPU
    4247 source_cpu_info = src_compute_info['cpu_info']
    4248 self._compare_cpu(source_cpu_info)

Please , confirm.