Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Issue is resolved. There were two problems.

The first is related to the "no such option: RI." Did a search in the keystone.conf file and found the "Ri" in the mysql connection password following a "$". Although the password was enclosed in single quotes because there were special characters in the password, the "$Ri" in the password was apparently being interpreted as a variable option which caused the error. Changing the password resolved the error.

Once the above error was resolved, a MySQL authentication error occurred, "Access denied for user 'keystone'@'controller' (using password: Yes)." Resolved this issue by removing the single quotes that enclosed the password in the "connection = mysql://keystone:DB_PASS@controller/keystone" entry in the keystone.conf file. When the single quotes were removed from enclosing the password, "keystone_manage db_sync keystone" ran successfully and populated the keystone database.