Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

With devstack, it was pretty easy (and since it worked, I feel justified in posting the answer for those using devstack). Just added

Q_PLUGIN=ml2

the localrc, replacing the previous value of Q_PLUGIN (for me was openvswitch).

GRE worked with only that change. VXLAN is not working for me, after setting

Q_ML2_TENANT_NETWORK_TYPE=vxlan

Still trying to track that down.

More info on this page: https://wiki.openstack.org/wiki/Neutron/ML2

With devstack, it was pretty easy (and since it worked, I feel justified in posting the answer for those using devstack). Just added

Q_PLUGIN=ml2

to the localrc, replacing the previous value of Q_PLUGIN (for me it was openvswitch).

GRE worked with only that change. VXLAN is not working for me, after setting setting:

Q_ML2_TENANT_NETWORK_TYPE=vxlan

Still I'm still trying to track that down.down. Could be some issue with fragementation/MTUs. I see vxlan packets flying around, but my guest VMs can't do dhcp and thus come up with no IP address on the veth.

More info on this page: https://wiki.openstack.org/wiki/Neutron/ML2