Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ok, that's the latest supported version by kilo. The problem is that consisgroup-create is a v2 API and by default, it's still use v1.

A workaround would be forcing cinderclient to use v2 export OS_VOLUME_API_VERSION=2 or cinder --os-volume-api-version=2 consisgroup-create

Ok, that's python-cinderclient-1.1.1-1.el7.noarch is the latest supported version by kilo. kilo. The problem is that consisgroup-create is a v2 API and by default, it's still use v1.

A workaround would be forcing cinderclient to use v2 v2

export OS_VOLUME_API_VERSION=2

or

cinder --os-volume-api-version=2 consisgroup-create

consisgroup-create

According to the ChangeLog, it has been introduced in python-cinderclient 1.1.0 and RDO ships 1.1.1 "Add support for ConsistencyGroups" - python-cinderclient-1.1.1-1.el7.noarch is the latest supported version by kilo. The problem is that consisgroup-create is a v2 API and by default, it's the client is still use using v1.

A workaround would be forcing cinderclient to use v2

export OS_VOLUME_API_VERSION=2

or

cinder --os-volume-api-version=2 consisgroup-create