Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Please make sure your configuration in haproxy is correct, I'm not sure what your issue is but for me the HTTP response was not in the 200-300 range which caused Haproxy to think it was down.

This is how I did it, and it works fine.

listen glance_api
        bind 192.168.107.10:9292
        balance  source
        option  tcpka
        option  httpchk
        option  tcplog
        server image1-sto1-os1 192.168.107.41:9292 check inter 2000 rise 2 fall 5

listen glance_registry
        bind 192.168.107.10:9191
        balance  source
        option  tcpka
        option  tcplog
        server image1-sto1-os1 192.168.107.41:9191 check inter 2000 rise 2 fall 5