Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I have resolved the "openstack service create" problem following this steps :

HTTP and KEYSTONE service sharing the same port, so stop httpd, modify the file /etc/httpd/conf.d/wsgi-keystone.conf and change the ports (5000 to 5001, 35357 to 35358) then start openstack-keystone.service and httpd.service.

Connect to mysql keystone DB and create the table "service": mysql -uroot -p => use keystone => CREATE TABLE service (id VARCHAR(64), type VARCHAR(255), extra TEXT,enabled TINYINT(1));

And finally, exec "openstack service create --name keystone --description "OpenStack Identity" identity" command.

Antonio

I have resolved the "openstack service create" problem following this steps :

HTTP and KEYSTONE service sharing the same port, so stop httpd, modify the file /etc/httpd/conf.d/wsgi-keystone.conf httpd and change the ports (5000 start openstack-keystone.service. Edit /etc/keystone/keystone.conf and replace "hostname or ip" to 5001, 35357 to 35358) then start openstack-keystone.service and httpd.service."localhost":

Connect connection = mysql://keystone:openstack@localhost/keystone

Remember to mysql keystone DB disable and create the table "service": mysql -uroot -p => use keystone => CREATE TABLE stop service (id VARCHAR(64), type VARCHAR(255), extra TEXT,enabled TINYINT(1));httpd and enable start service keystone:

systemctl disable httpd.service systemctl stop httpd.service

systemctl enable openstack-keystone.service systemctl start openstack-keystone.service

And finally, exec "openstack service create --name keystone --description "OpenStack Identity" identity" command.

Antonio

I have resolved the "openstack service create" problem following this steps :

HTTP and KEYSTONE service sharing the same port, so stop httpd and start openstack-keystone.service. Edit /etc/keystone/keystone.conf and replace "hostname or ip" to "localhost":

connection = mysql://keystone:openstack@localhost/keystone

Remember to disable and stop service httpd and enable start service keystone:

systemctl disable httpd.service keystone: - systemctl stop httpd.service

httpd.service - systemctl enable openstack-keystone.service openstack-keystone.service => systemctl start openstack-keystone.service

And finally, exec "openstack service create --name keystone --description "OpenStack Identity" identity" command.

Most important to remember, the dashboard horizon use apache so that keystone and apache service must be running. Into keystone.conf and wsgi-keystone.conf occur bind a single interface on ports 5000 and 35357 instead of all interface "*" or "0.0.0.0":

  • edit /etc/keystone/keystone.conf => set admin_bind_host = <ip_mgmt> => set public_bind_host = <ip_mgmt>
  • edit /etc/httpd/conf.d/wsgi-keystone.conf => set Listen 127.0.0.1:5000 => Listen 127.0.0.1:35357 => same for VirtualHost 127.0.0.1:5000 & 35357

After service openstack-keystone.service and httpd.service restart, both process will be running in the same time.

Antonio