Ask Your Question

Revision history [back]

Due to known issue with "G+" logins I cannot update my original feed and use another one to responde

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hosrtname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Due to known issue with "G+" logins https://bugs.launchpad.net/openstack-community/+bug/1418361
I cannot update my original feed and use another one to responde

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hosrtname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Due to known issue with "G+" logins https://bugs.launchpad.net/openstack-community/+bug/1418361
I cannot update my original feed and use another one to responde

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then
packstack by default performs ML2&OVS&VXLAN setup on single host

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hosrtname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Due to known issue with "G+" logins https://bugs.launchpad.net/openstack-community/+bug/1418361
I cannot update my original feed and use another one to responderespond

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then
packstack by default performs ML2&OVS&VXLAN setup on single host

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hosrtname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Due to known issue with "G+" logins https://bugs.launchpad.net/openstack-community/+bug/1418361
I cannot update my original feed and use another one to respond

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then
packstack by default performs ML2&OVS&VXLAN setup on single host

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hosrtname [root@aio-hostname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Due to known issue with "G+" logins https://bugs.launchpad.net/openstack-community/+bug/1418361
I cannot update my original feed and use another one to respond

I presume , that you have performed RDO Juno AIO install via `packstack --allinone`, then
packstack by default performs ML2&OVS&VXLAN setup on single host

# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="10.3.3.219"
NETMASK="255.255.255.0"
DNS1="8.8.8.8"
BROADCAST="10.3.3.255"
GATEWAY="10.3.3.1"  <== should be real gateway's IP on office LAN
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

Your plugin.ini should look like :-

[root@aio-hostname neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      197 May 11 17:07 api-paste.ini
drwxr-xr-x. 8 root root     4096 May 11 17:06 conf.d
-rw-r-----. 1 root neutron  3605 Apr 30 15:52 dhcp_agent.ini
-rw-r-----. 1 root neutron  5035 Apr 30 15:52 l3_agent.ini
-rw-r-----. 1 root neutron  2512 Apr 30 15:52 metadata_agent.ini
-rw-r-----. 1 root neutron 36245 May 11 17:07 neutron.conf
lrwxrwxrwx. 1 root root       37 May 11 17:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 3 root root       16 May 11 17:06 plugins
-rw-r-----. 1 root neutron  7140 Apr 30 15:52 policy.json
-rw-r--r--. 1 root root     1164 Apr 30 15:52 rootwrap.conf
[root@aio-hostname neutron(keystone_admin)]# cat plugin.ini | grep -v ^#| grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

$ source keystonerc_demo
$ nova secgroup-list-rules default

+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+