Revision history [back]

click to hide/show revision 1
initial version

Option 1:

It clearly says "2015-04-25 14:44:50.871 2216 TRACE keystone.common.wsgi DBConnectionError: (OperationalError) (2006, 'MySQL server has gone away'"

You have dbconnectionerror, check the username and password, if everything is correct try to restart the mysql and mariadb. Hope this will fix your problem.

Option 2:

a. Server timed out and closed the connection. To fix, check that “wait_timeout” mysql variable in your my.cnf configuration file is large enough.

b. Server dropped an incorrect or too large packet. If mysqld gets a packet that is too large or incorrect, it assumes that something has gone wrong with the client and closes the connection. To fix, you can increase the maximal packet size limit “max_allowed_packet” in my.cnf file, eg. set max_allowed_packet = 128M, then sudo /etc/init.d/mysql restart.

Option 1:

It clearly says "2015-04-25 14:44:50.871 2216 TRACE keystone.common.wsgi DBConnectionError: (OperationalError) (2006, 'MySQL server has gone away'"

You have dbconnectionerror, check the username and password, if everything is correct try to restart the mysql and mariadb. Hope this will fix your problem.

Option 2:

a. Server timed out and closed the connection. To fix, check that “wait_timeout” mysql variable in your my.cnf configuration file is large enough.

b. Server dropped an incorrect or too large packet. If mysqld gets a packet that is too large or incorrect, it assumes that something has gone wrong with the client and closes the connection. To fix, you can increase the maximal packet size limit “max_allowed_packet” in my.cnf file, eg. set max_allowed_packet = 128M, then sudo /etc/init.d/mysql restart. restart.

Option 3:

Check whether all your services are running or not? especially check for rabbitmq status. If its stoped restart it and restart other services.