Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Try changing the MTU to allow the extra bits of the tunnel to make into the tunnel packet due to DNSMasq requiring unfragmented packets.

cat > ${NEUTRON_DHCP_AGENT_INI} << EOF

[DEFAULT]

interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver

dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq

use_namespaces = True

dnsmasq_config_file=/etc/neutron/dnsmasq-neutron.conf

EOF

cat > /etc/neutron/dnsmasq-neutron.conf << EOF

dhcp-option-force=26,1400

EOF