Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The problem is the MTU. Inside the VM (maybe you can use the console to log in) you can set the mtu of the instance to 1400. So, to correct this problem in the living instance you have to put the mtu down.

 sudo ip link set eth0  mtu 1400

In your neutron controller, you must configure your dhcp_agent.ini

[DEFAULT]
....
dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf

And

echo dhcp-option-force=26,1400" >> /etc/neutron/dnsmasq-neutron.conf

Restart the neutron-server, neutron-dhcp-agent and the instances you create from this moment on will be accesible using ssh. And the existing instances will need a reboot.

The problem is the MTU. Inside the VM (maybe you can use the console to log in) you can set the mtu of the instance to 1400. So, to correct this problem in the living instance you have to put lower the mtu down.mtu.

 sudo ip link set eth0  mtu 1400

In your neutron controller, you must configure your dhcp_agent.ini

[DEFAULT]
....
dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf

And

echo dhcp-option-force=26,1400" >> /etc/neutron/dnsmasq-neutron.conf

Restart the neutron-server, neutron-dhcp-agent and the instances you create from this moment on will be accesible using ssh. And the existing instances will need a reboot.