Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I had this issue too and spent almost two months debugging it. I tried tweaking MTUs, enabling jumbro frames and everything. The issue ended up being with GRO where the server was offloading network processing off to the NIC. I disabled that, restarted the interface and my speeds increased by 8x.

Disable gro for an interface (temporary, if the machine restarts, this will be lost) with:

ethtool -K <interface> gro off

You can disable it permanently (on CentOS/RHEL at least) by adding this to the respective interface's network script:

ETHTOOL_OPTS="gro off"

The script (on RHEL/CentOS) is found at:

/etc/sysconfigs/network-scripts/ifcfg-<interface>