Ask Your Question

Revision history [back]

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

       keytone token-get

  curl -ki -X GET \
-H 'User-Agent: python-glanceclient' \
-H 'Content-Type: application/octet-stream'   \
-H 'Accept-Encoding: gzip, deflate' \
-H 'Accept: */*'   \
-H 'X-Auth-Token: <ID for the  keystone token-get response>
'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
</pre>

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command command

 keytone token-get

 keytone token-get

   curl -ki -X GET \
 -H 'User-Agent: python-glanceclient' \
 -H 'Content-Type: application/octet-stream'   \
 -H 'Accept-Encoding: gzip, deflate' \
 -H 'Accept: */*'   \
 -H 'X-Auth-Token: <ID for the <id for="" the="" keystone="" token-get="" response="">
 keystone token-get response>
 'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
</pre>
 

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1: In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You shohld be able to get a token using that username/password/tenant name.

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1: In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You shohld should be able to get a token using that username/password/tenant name.

name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1: 1:

In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You should be able to get a token using that username/password/tenant name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1:

In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You should be able to get a token using that username/password/tenant name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Update 2:

  Try this
 keystone  --os-username glance --os-password <glance user="" password=""> --os-tenant-name service  --os-auth-url  "http://localhost:35357"  token-get

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1:

In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You should be able to get a token using that username/password/tenant name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Update 2:

Try this

  Try this
 keystone  --os-username glance --os-password <glance user="" password=""> user password> --os-tenant-name service  --os-auth-url  "http://localhost:35357"  token-get

"https://ost-el7.example.com:35357/v2.0" token-get

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1:

In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You should be able to get a token using that username/password/tenant name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Update 2:

Try this

 keystone  --os-username glance --os-password <glance user password> --os-tenant-name service services  --os-auth-url      "https://ost-el7.example.com:35357/v2.0"  token-get

Couple of things are wrong here.

1) You can't take the token from the curl command shown in debug. That is mangled token and not the real token. Real token won't have {SHA1}

2) Frist verify the glance is working fine. I have removed cert options and added "-k" for curl. Also you need to add the token from keystone token-get command

      keytone token-get

       curl -ki -X GET \
    -H 'User-Agent: python-glanceclient' \
    -H 'Content-Type: application/octet-stream'   \
    -H 'Accept-Encoding: gzip, deflate' \
    -H 'Accept: */*'   \
    -H 'X-Auth-Token: <id for="" the="" keystone="" token-get="" response="">
    'https://ost-el7.example.com:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20' ; echo
    

3) Also what is your environment setting, especially the values of the varaibles OS_*. Since you are able to get the token, most probably it is not cert issue.

Update 1:

In your glance.conf under keystone_authtoken section, there will be username/password and tenant name. Is that correct? You should be able to get a token using that username/password/tenant name. Please check that.

Since your are able to get token using for admin username with admin tenant, you can also use those credentials in glance.conf

Update 2:

Try this

 keystone  --os-username glance --os-password <glance user password> --os-tenant-name services  --os-auth-url      "https://ost-el7.example.com:35357/v2.0"  token-get

Normally those setup scripts creates project with the name "service", but you have "services" in your config file. Above command should help you to check that out