Revision history [back]

click to hide/show revision 1
initial version

Thanks! I actually found out the issue. According the Juno install docs for opensuse, it says to add the .persistence. keyword to the [token] portion of the /etc/keystone/keystone.conf file. Like this: ... [token] # Provides token persistence. driver = keystone.token.persistence.backends.sql.Token ....

After removing the persistence word, I had no issue. I restarted openstack-keystone, it brought the ports up, I was able to connect to them, and I finished the keystone install last night... Again I removed the word persistence from the drive parameter, and it worked.

driver = keystone.token.backends.sql.Token

They ask you to place the keyword "persistence" in between token and backends. It causes the keystone.conf file to not be fully loaded, and the port's listed in the same file, will not be opened up.