Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The subnet associated with your external network has gateway_ip 172.31.116.1. This needs to be the IP address of some real router on the link that eth0 is connected to. You should be able to ping it from the router namespace as br-ex bridges qg-5366ad09-03 and eth0. For some reason you cannot. Can you provide the tcpdump. Is this setup running in virtual machines?

I have no idea what the 129.132.32.7/26 on br-ex is for. I would remove it and leave this bridge dedicated to external access for Neutron routers for now.

The subnet associated with your external network has gateway_ip 172.31.116.1. This needs to be the IP address of some real router on the link that eth0 is connected to. You should be able to ping it from the router namespace as br-ex bridges qg-5366ad09-03 and eth0. For some reason you cannot. Can you provide the tcpdump. Is this setup running in virtual machines?

I have no idea what the 129.132.32.7/26 on br-ex is for. I would remove it and leave this bridge dedicated to external access for Neutron routers for now.

Update: ok, so the controller/network node is a VMware VM. I don't know how VMware networking works, but it may be that the VMware virtual switch/bridge is not writing packets to the Nic you have put in br-ex, because the destination mac in the packets is that of qg-xxxxxx-xx interface (tcpdump -e) and not the VMware nic. In VMware can you try setting the Nic for eth0 (or whatever nic is in br-ex) to promiscuous mode - then it should write all packets.

The subnet associated with your external network has gateway_ip 172.31.116.1. This needs to be the IP address of some real router on the link that eth0 is connected to. You should be able to ping it from the router namespace as br-ex bridges qg-5366ad09-03 and eth0. For some reason you cannot. Can you provide the tcpdump. Is this setup running in virtual machines?

I have no idea what the 129.132.32.7/26 on br-ex is for. I would remove it and leave this bridge dedicated to external access for Neutron routers for now.

Update: ok, so the controller/network node is a VMware VM. I don't know how VMware networking works, but it may be that the VMware virtual switch/bridge is not writing packets to the Nic you have put in br-ex, because the destination mac in the packets is that of the qg-xxxxxx-xx interface (tcpdump -e) and not the VMware nic. In VMware can you try setting the Nic for eth0 (or whatever nic is in br-ex) to promiscuous mode - then it should write all packets.