Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Now the problem of 'CommunicationError at /project/images/ Error finding address for htt p://10.0.1.15: 9292/v1/images/detail?sort_key=created_at&sort_dir=desc&limit=1000: ('Connection aborted.', error(111, 'Connection refused'))'is solved, I give my solution as a reference:

The problem occurred when I set my localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=eth0

FLOATING_RANGE={-...not important for this case}

(module passwords....)

Here, my network setting is actually: eth0:dhcp(Virtualbox NAT give it IP), eth1: static IP: 10.0.1.15(Virtualbox host-only network)

The problem is solved by setting localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=br100

PUBLIC_INTERFACE=eth1

FLOATING_RANGE={-...not important for this case}

(module passwords....)

In this setting, I changed my /etc/network/interfaces as:

eth0:dhcp, br100+eth1:static IP:10.0.1.15

I guess the problem is solved because I changed FLAT_INTERFACE from eth0 to eth1. eth1 is the entry to the openstack host.

The error of 'Unable to retrieve usage information' is still there, so I will take Yashpal's advice to see what's going on

Now the problem of 'CommunicationError at /project/images/ Error finding address for htt p://10.0.1.15: 9292/v1/images/detail?sort_key=created_at&sort_dir=desc&limit=1000: ('Connection aborted.', error(111, 'Connection refused'))'is is solved, I give my solution as a reference:

The problem occurred when I set my localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=eth0

FLOATING_RANGE={-...not important for this case}

(module passwords....)

Here, my network setting is actually: eth0:dhcp(Virtualbox NAT give it IP), eth1: static IP: 10.0.1.15(Virtualbox host-only network)

The problem is solved by setting localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=br100

PUBLIC_INTERFACE=eth1

FLOATING_RANGE={-...not important for this case}

(module passwords....)

In this setting, I changed my /etc/network/interfaces as:

eth0:dhcp, br100+eth1:static IP:10.0.1.15

I guess the problem is solved because I changed FLAT_INTERFACE from eth0 to eth1. eth1 is the entry to the openstack host.

The error of 'Unable to retrieve usage information' is still there, so I will take Yashpal's advice to see what's going on