Ask Your Question

Revision history [back]

I answered this here: [https://ask.openstack.org/en/question/58604/1-is-not-supported-api-version-example-values-1-or-2-in-glance/]

But just for reference:

You don't have the netifaces installed since you're getting that error.

Fix this by installing it:

sudo pip install netifaces

Then verify:

glance --os-image-api-version 2 image-list

Should get back:

+-----+-------+
| ID   | Name|
+-----+-------+

Then rerun your glance image-create