Ask Your Question

Revision history [back]

How about starting at docs.openstack.org and clicking on Installation Guide for Ubuntu 14.04

Ubuntu wont support Juno on 12.04 so if you want Juno you need to go to 14.04.

If you are okay with IceHouse you can do it on 12.04 Installation Guide for Ubuntu 12.04

These are full step by step guides.