Ask Your Question

Revision history [back]

Use as comment. Suspect SELINUX is not set to permissive mode :-

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

Use as comment. Suspect SELINUX is not UPDATE 1

You wrote : you were right, I forgot to set it to permissive mode :-through setenforce 0

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

=============================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

============================================================================================================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would be a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

===============================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would be a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

====================================================================================================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would be a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

=========================================================================================================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Per official RDO instructions SELINUX should be set to permissive before running packstack

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would be a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

====================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.

UPDATE 2

 RDO Juno AIO install on CentOS 7 (KVM) with SELINUX enforced 
    has been done. During install there was just one AVC denial alert
    related with Nova , not with Neutron. After install I attempted to activate
    DHCP for demo_private network via dnsmasq and failed. AVC denial
    protocol was captured and uploaded to following location along with
    my actions.

View :- http://bderzhavets.blogspot.com/2014/12/testing-juno-on-centos-7-with-selinux.html

UPDATE 1

You wrote : you were right, I forgot to set it to permissive through setenforce 0

Per official RDO instructions SELINUX should be set to permissive before running packstack

Dnsmasq makes an attempt set attribute on /var/log/neutron folder && search in

/var/lib/neutron
/var/log/neutron

directories , which gets blocked SELINUX no matter of current 755. Could you,please,
upload somewhere "grep dnsmasq /var/log/audit/audit.log".
As far AVC denial would come up it would be a fair.
I've installed Juno on CentOS 7 for MultiNode Deployment several times
and never had problems with demo_network created by packstack.
View also https://bugzilla.redhat.com/show_bug.cgi?id=996776

There is another way to test . I just guess :
Enable SELINUX  and your new private network which is fine right now,
will demonstrate dnsmasq access problems, regardless 755 will  be still in place.
Just  see Warnings in "service neutron-dhcp-agent status -l" on my working Network Node.

====================================================================================

[root@juno1 ~(keystone_admin)]# service neutron-dhcp-agent status
Redirecting to /bin/systemctl status  neutron-dhcp-agent.service
neutron-dhcp-agent.service - OpenStack Neutron DHCP Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-dhcp-agent.service; enabled)
   Active: active (running) since Tue 2014-12-09 07:49:42 MSK; 6h ago
 Main PID: 3585 (neutron-dhcp-ag)
   CGroup: /system.slice/neutron-dhcp-agent.service
           ├─3585 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file /usr/share/neutron/neutron...
           ├─5872 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap305cf...
           ├─5879 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap5532b...
           ├─5887 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap37cfc...
           ├─5889 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap2d26c...
           └─6015 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapec79a...

Dec 09 07:50:10 juno1.localdomain sudo[5943]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:10 juno1.localdomain sudo[5949]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...faa
Dec 09 07:50:10 juno1.localdomain sudo[5956]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/... up
Dec 09 07:50:11 juno1.localdomain sudo[5973]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...bal
Dec 09 07:50:11 juno1.localdomain sudo[5987]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[5993]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ink
Dec 09 07:50:11 juno1.localdomain sudo[5999]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:11 juno1.localdomain sudo[6003]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...-04
Dec 09 07:50:12 juno1.localdomain sudo[6008]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/...ace
Dec 09 07:50:12 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from search...y .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from open a...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Dec 09 07:50:13 juno1.localdomain python[5875]: SELinux is preventing /usr/sbin/dnsmasq from setatt...e .

                                                *****  Plugin catchall (100. confidence) suggests   **...
Hint: Some lines were ellipsized, use -l to show in full.