Ask Your Question

Revision history [back]

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) in /var/log/nova/compute.log. Switching libvirt_type=qemu inside nova.conf, enabled "kvm" support on laptop && eliminated Unicode issue and brought RDO Juno to working shape.

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) in /var/log/nova/compute.log. Switching libvirt_type=qemu inside nova.conf, enabled "kvm" support on laptop MacBook Pro && eliminated Unicode issue and brought RDO Juno to working shape.

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) in /var/log/nova/compute.log. Switching libvirt_type=qemu inside nova.conf, enabled "kvm" Virtualization support on MacBook Pro && eliminated Unicode issue and brought RDO Juno to working shape.shape. I would suggest to test :-

compute_driver = libvirt.LibvirtDriver
[libvirt]
virt_type = kvm

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) which meant Internal error: No supported architecture for OS-Type 'hvm' in /var/log/nova/compute.log. /var/log/nova/compute.log.
Switching libvirt_type=qemu inside nova.conf, enabled Virtualization support on MacBook Pro && eliminated Unicode issue and brought RDO Juno to working shape. I would suggest to test :-

compute_driver = libvirt.LibvirtDriver
[libvirt]
virt_type = kvm

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) which meant Internal error: No supported architecture for OS-Type 'hvm' in /var/log/nova/compute.log.
Switching libvirt_type=qemu inside nova.conf, enabled Virtualization support on MacBook Pro && eliminated Unicode issue and brought RDO Juno to working shape. I would suggest to test :-

Depending on CPU

    # lsmod | grep kvm
    # modprobe -a kvm-intel
       or
    # modprobe -a kvm-amd

Update nova.conf

 compute_driver = libvirt.LibvirtDriver
 [libvirt]
 virt_type = kvm

Setting debug=True in nova.conf, generated message in German ( non ASCII characters) which meant Internal error: No supported architecture for OS-Type 'hvm' in /var/log/nova/compute.log.
Switching libvirt_type=qemu inside nova.conf, enabled Virtualization support on MacBook Pro && eliminated Unicode issue and brought RDO Juno to working shape. I would suggest to test :-Applied fix is correct per
https://ask.openstack.org/en/question/7519/instance-error-caused-by-libvirterror-internal-error-no-supported-architecture-for-os-type-hvm/

Depending on CPU

    # lsmod | grep kvm
    # modprobe -a kvm-intel
       or
    # modprobe -a kvm-amd

Update nova.conf

 compute_driver = libvirt.LibvirtDriver
    [libvirt]
    virt_type = kvm