Ask Your Question

Revision history [back]

Ensure that your nova-api service is running on your host (in your case IP 192.168.100.98) and is listening on port 8774. Port 8774 corresponds to nova-compute service, it's needed for authorizing to keystone service.

You need to check for the nova-api service logs (devstack defaults to /var/log/nova/api.log) to determine the cause of service start up failure. Paste the logs onto http://paste.openstack.org and provide the link in your question (edit it, don't add comments).

First thing is to make sure that you're following the right instructions to install devstack. There are lots of blog posts and other results online but the very step is to follow the official devstack documentation. If things don't work, the first thing to do is to make sure you're checking out the correct, latest, stable code and the tested configuration.

Ensure that your nova-api service is running on your host (in your case IP 192.168.100.98) and is listening on port 8774. Port 8774 corresponds to nova-compute service, it's needed for authorizing to keystone service.

You need to check for the nova-api service logs (devstack defaults to /var/log/nova/api.log) to determine the cause of service start up failure. Paste the logs onto http://paste.openstack.org and provide the link in your question (edit it, don't add comments).

First thing is to make sure that you're following the right instructions to install devstack. There are lots of blog posts and other results online but the very step is to follow the official devstack documentation. If things don't work, the first thing to do is to make sure you're checking out the correct, latest, stable code and the tested configuration.

Ensure that your nova-api service is running on your host (in your case IP 192.168.100.98) and is listening on port 8774. Port 8774 corresponds to nova-compute service, it's needed for authorizing to keystone service.

You need to check for the nova-api service logs (devstack defaults to /var/log/nova/api.log) to determine the cause of service start up failure. Paste the logs onto http://paste.openstack.org and provide the link in your question (edit it, don't add comments).comments). To enable debugging, have a look at these answers.