Ask Your Question

Revision history [back]

Setting the proxy inside /etc/yum.conf works immediately.

Add the following line to /etc/yum.conf: proxy=http://Proxy-IP:Port

and also you may need to add to $HOME/.bashrc

http_proxy=http://IP-PROXY:PORT-PROXY; export http_proxy
no_proxy="localhost,127.0.0.1"; export no_proxy

Setting the proxy inside /etc/yum.conf works immediately.

Add the following line to /etc/yum.conf: proxy=http://Proxy-IP:Port

and also Also if you may need to add setup proxy env variables for general external HTTP access, you might need to adjust openstack settings to avoid the proxy for internal openstack services. Add to $HOME/.bashrc

http_proxy=http://IP-PROXY:PORT-PROXY; export http_proxy
no_proxy="localhost,127.0.0.1"; export no_proxy