Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi,

The issue seems to be related with AMQP server. I would suggest you to verify the rabbitmq status and make sure that your openstack nodes are able to connect with rabbitmq server. I have also configured the openstack with Juno release and my rabbitmq settings are as below:-

rpc_backend=rabbit

rabbit_host=controller

rabbit_user=guest

rabbit_password=Password

Where password is specific to your installation and you may try changing the rpc_backend to 'rabbit'. You need to make the similar settings in all your openstack nodes configuration files.

I would also suggest you to change the debug mode 'true' in nova configuration file as below:

debug=True

Restart the nova compute service and check the logs again for more detailed messages.

Hi,

The issue seems to be related with AMQP server. I would suggest you to verify the rabbitmq status and make sure that your openstack nodes are able to connect with rabbitmq server. I have also configured the openstack with Juno release and my rabbitmq settings are as below:-

rpc_backend=rabbit

rabbit_host=controller

rabbit_user=guest

rabbit_password=Password

rpc_backend=rabbit
rabbit_host=controller
rabbit_user=guest
rabbit_password=Password

Where password is specific to your installation and you may try changing the rpc_backend to 'rabbit'. You need to make the similar settings in all your openstack nodes configuration files.

I would suggest you to verify the 'RabbitMQ status' and make sure that all OpenStack nodes are able to ping/connect with RabbitMQ server.

To verify if RabbitMQ service is running on your rabbit server, run below command: -

#systemctl status rabbitmq-server.service -l

To verify the RabbitMQ server status run the below command: -

#rabbitmqctl status

This command should print a detailed output of various information related to AMQP server. If the status is good then you need to make sure that rabbitmq port is allowed to make connection between your openstack nodes through firewall.

On RabbitMQ server you may run the below command to check if your compute node is able to establish connection with rabbit server:-

   # lsof -i :5672|grep 'compute_node_ip'

Make sure that there is no time lag between your openstack node, all the nodes should be synced with a central server time using NTP.

I would also suggest you to change the debug mode 'true' in nova configuration file as below:

debug=True

Restart the nova compute service and check the logs again for more detailed messages.

Hi,

The issue seems to be related with AMQP server. I have also configured the openstack with Juno release and my rabbitmq settings are as below:-

rpc_backend=rabbit
rabbit_host=controller
rabbit_user=guest
rabbit_password=Password

Where password is specific to your installation and you may try changing the rpc_backend to 'rabbit'. You need to make the similar settings in all your openstack nodes configuration files.

I would suggest you to verify the 'RabbitMQ status' and make sure that all OpenStack nodes are able to ping/connect with RabbitMQ server.

To verify if RabbitMQ service is running on your rabbit server, run below command: -

#systemctl status rabbitmq-server.service -l

To verify the RabbitMQ server status run the below command: -

#rabbitmqctl status

This command should print a detailed output of various information related to AMQP server. If the status is good then you need to make sure that rabbitmq port is allowed to make connection between your openstack nodes through firewall.

On RabbitMQ server you may run the below command to check if your compute node is able to establish connection with rabbit server:-

   # lsof -i :5672|grep 'compute_node_ip'

Make sure that there is no time lag between your openstack node, all the nodes should be synced with a central server time using NTP.

I would also suggest you to change the debug mode 'true' in nova configuration file as below:

debug=True

debug=True

Restart the nova compute service and check the logs again for more detailed messages.