Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

[ {rabbit, [ {default_user, <<"guest">>}, {default_pass, <<"guest">>} ]}, {kernel, [ ]} ].

% EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use_epel=y ... ... (wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started .

// Then on another term window, manually stop the MQ service, $ sudo service rabbitmq-server stop

// overwrite the /etc/rabbitmq/rabbitmq.config file with the below config : [{rabbit, [{loopback_users, []}]}]. % EOF

// and restart the service $ sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use_epel=y )

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :


[ {rabbit, [ {default_user, <<"guest">>}, {default_pass, <<"guest">>} ]}, {kernel, [ ]} ].

]. % EOF


The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use_epel=y ... ... (wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started .

// Then on another term window, manually stop the MQ service, $ sudo service rabbitmq-server stop

// overwrite the /etc/rabbitmq/rabbitmq.config file with the below config : [{rabbit, [{loopback_users, []}]}]. % EOF

// and restart the service $ sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use_epel=y )

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :


[ {rabbit, [ {default_user, <<"guest">>}, {default_pass, <<"guest">>} ]}, {kernel, [ ]} ]. % EOF


The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use_epel=y ... ... (wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started .

// Then on another term window, manually stop the MQ service, $ sudo service rabbitmq-server stop

// overwrite the /etc/rabbitmq/rabbitmq.config file with the below config : [{rabbit, [{loopback_users, []}]}]. % EOF

// and restart the service $ sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use_epel=y )

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

 [
   {rabbit, [
     {default_user, <<"guest">>},
     {default_pass, <<"guest">>}
   ]},
   {kernel, [
   ]}
 ].
 % EOF

EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use_epel=y
...
...
(wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started . 

// Then on another term window, manually stop the MQ service, $ sudo service rabbitmq-server stop

stop // overwrite the /etc/rabbitmq/rabbitmq.config file with the below config : [{rabbit, [{loopback_users, []}]}]. % EOF

EOF // and restart the service $ sudo service rabbitmq-server start

start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use_epel=y )

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

    [
      {rabbit, [
        {default_user, <<"guest">>},
        {default_pass, <<"guest">>}
      ]},
      {kernel, [
      ]}
    ].

% EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use_epel=y
--use-epel=y
...
...
(wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started . 

// Then on another term window, manually stop the MQ service,
$  sudo service rabbitmq-server stop

//  overwrite the /etc/rabbitmq/rabbitmq.config file with the below config :
[{rabbit, [{loopback_users, []}]}].
% EOF

// and restart the service 
$  sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use_epel=y --use-epel=y )

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

    [
      {rabbit, [
        {default_user, <<"guest">>},
        {default_pass, <<"guest">>}
      ]},
      {kernel, [
      ]}
    ].

% EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use-epel=y
...
...
(wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started . 

// Then on another term window, manually stop the MQ service,
$  sudo service rabbitmq-server stop

//  overwrite the /etc/rabbitmq/rabbitmq.config file with the below config :
[{rabbit, [{loopback_users, []}]}].
% EOF

// and restart the service 
$  sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use-epel=y ) or answer-file option.

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.