Ask Your Question

Revision history [back]

I bumped to this problem as well. Seems that the nova-novncproxy requires exactly nova-common 2013.1-2 and no newer. What I did was extracting the original deb package, allowing newer nova-common and packaging the packet back. After installation I did not get any problems with cinder or other installations.

1) wget http://archive.gplhost.com/debian/pool/grizzly/main/n/nova/nova-novncproxy_2013.1-2_all.deb 2) dpkg -x nova-novncproxy_2013.1-2_all.deb tmp 3) dpkg-deb --control nova-novncproxy_2013.1-2_all.deb 4) vim DEBIAN/control Changed the row Depends to be: Depends: nova-common (>= 2013.1-2), lsb-base (>= 3.0.6), python 5) mv DEBIAN tmp 6) dpkg -b tmp nova-novncproxy_2013.1-2n_all.deb 7) dpkg -i nova-novncproxy_2013.1-2n_all.deb

-Mika

I bumped to this problem as well. Seems that the nova-novncproxy requires exactly nova-common 2013.1-2 and no newer. What I did was extracting the original deb package, allowing newer nova-common and packaging the packet back. After installation I did not get any problems with cinder or other installations.

1) wget http://archive.gplhost.com/debian/pool/grizzly/main/n/nova/nova-novncproxy_2013.1-2_all.deb http://archive.gplhost.com/debian/pool/grizzly/main/n/nova/nova-novncproxy_2013.1-2_all.deb
2) dpkg -x nova-novncproxy_2013.1-2_all.deb tmp tmp
3) dpkg-deb --control nova-novncproxy_2013.1-2_all.deb nova-novncproxy_2013.1-2_all.deb
4) vim DEBIAN/control DEBIAN/control
Changed the row Depends to be: be:
Depends: nova-common (>= 2013.1-2), lsb-base (>= 3.0.6), python python
5) mv DEBIAN tmp tmp
6) dpkg -b tmp nova-novncproxy_2013.1-2n_all.deb nova-novncproxy_2013.1-2n_all.deb
7) dpkg -i nova-novncproxy_2013.1-2n_all.deb

-Mika