Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The answer I eventually found that solved my problem:

  • Keystone is actually the rogue process that is sitting on port 5000.
  • The "unstack.sh" in the latest master in the stable/icehouse that i have, is not entirely undoing the stacking process of the previous icehouse that was in place. It does not clean everything off from the previous devstack (icehouse stable from 4 months ago) that was running on the system. Particularly, cleaning up the keystone process running at port 5000 was not being done by this "unstack.sh". (NB: No amount of unstacking with the newer devstack icehouse will remove all traces properly of an older devstack because the scripts seem to be different. Even using the "clean.sh" didn't do the trick).
  • In the current version of icehouse, keystone is now being started up by apache, that's why apache is seen to be trying to bind to port 5000

The fix itself that worked for me was to remove the "keystone.conf" and recreate a blank one in it's place:

sudo rm /etc/apache2/sites-available/keystone.conf
sudo touch /etc/apache2/sites-available/keystone.conf

The ./unstack.sh, ./clean.sh, remove all traces of mysql (as described here: http://stackoverflow.com/questions/10853004/removing-mysql-5-5-completely ) ... and finally ./stack.sh again

The reason why i created an empty keystone.conf file was that when i removed it and "unstacked" and "stacked" again, for some reason a new "keystone.conf" file was not being created. The devstack installation script would just stop and throw some error about not being able to find the "keystone.conf" at the aforementioned location. Creating an empty one seems to have done the trick. I guess emptying the original keystone.conf might produce the same result as what i've done here.

You can read more about this problem and some parts of the solution here: https://bugs.launchpad.net/devstack/+bug/1340660