Ask Your Question

Revision history [back]

I solved by installing libffi and libffi-devel

My actual problem is that I don't have libffi installed. I can see hundreds of messages about not being able to find libffi in the setup steps, and getting C compiler errors trying to include ffi.h, and so on. So, what I need to do is install it.

This is a C library, not a Python library. My platform may have a package for it that I can install with yum or apt or brew or port or whatever; if not, I can download it and install it manually. (IIRC, you can just ./configure && make install, but read the docs.) On some platforms, I may also need a libffi-devel or libffi-dev or libffi-libs or similar package.