Ask Your Question

Revision history [back]

Hi fhussain,

I had faced the similar issue. I haven't looked at the code but it seems if you specify ENABLED_SERVICES in your localrc, it doesn't really look into services specified in "enable_service". This was perhaps the reason why the networking services remained disabled.

# disable_service n-net
# enable_service q-svc
# enable_service q-agt
# enable_service q-dhcp
# enable_service q-l3
# enable_service q-meta
# enable_service neutron
# Optional, to enable tempest configuration as part of devstack
# enable_service tempest
ENABLED_SERVICES += neutron,q-meta,q-l3,q-dhcp,q-agt,q-svc
ENABLED_SERVICES -= n-net

^This should help you solve your problem. Make sure ENABLED_SERVICES has been initialized before using it. Or put it afer # Services.

Let us know if this helps.

-Prasoon